Error occure when Copy Product - Beta2b vers.

Mar 17, 2010 at 8:57 AM

Description:

When I try to copy Product It give me error, but even thogh, the system dublicate it, but you need to refresh the page somehow

Event Details:

AssemblyVersion: 5.2.3
PortalID: 0
PortalName: AutoMEPS
UserID: 1
UserName: ghalib
ActiveTabID: 67
ActiveTabName: Store Menu
RawURL: /Admin/StoreMenu/tabid/67/ctl/AdminProduct/mid/385/Default.aspx?SkinSrc=%2fDesktopModules%2fNB_Store%2fSkins%2fStoreAdmin%2fNB_StoreAdmin
AbsoluteURL: /Default.aspx
AbsoluteURLReferrer: http://localhost/Admin/StoreMenu/tabid/67/ctl/AdminProduct/mid/385/Default.aspx?SkinSrc=%2fDesktopModules%2fNB_Store%2fSkins%2fStoreAdmin%2fNB_StoreAdmin
UserAgent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.2; GTB6.4; .NET CLR 1.1.4322; InfoPath.2; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.0.3705; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider
ExceptionGUID: 542b39ff-2d09-4a22-ad04-988610828839
InnerException: Object reference not set to an instance of an object.
FileName:
FileLineNumber: 0
FileColumnNumber: 0
Method: NEvoWeb.Modules.NB_Store.ProductController.CopyModels
StackTrace:
Message: DotNetNuke.Services.Exceptions.PageLoadException: Object reference not set to an instance of an object. ---> System.NullReferenceException: Object reference not set to an instance of an object. at NEvoWeb.Modules.NB_Store.ProductController.CopyModels(Int32 ProductID, String Lang, Int32 NewProductID, LocaleCollection supportedLanguages) at NEvoWeb.Modules.NB_Store.ProductController.CopyProduct(Int32 ProductID) at NEvoWeb.Modules.NB_Store.AdminProductList.dgProducts_ItemCommand(Object source, DataGridCommandEventArgs e) at System.Web.UI.WebControls.DataGrid.OnItemCommand(DataGridCommandEventArgs e) at System.Web.UI.WebControls.DataGrid.OnBubbleEvent(Object source, EventArgs e) at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) at System.Web.UI.WebControls.DataGridItem.OnBubbleEvent(Object source, EventArgs e) at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) at System.Web.UI.WebControls.ImageButton.OnCommand(CommandEventArgs e) at System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) at System.Web.UI.WebControls.ImageButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) --- End of inner exception stack trace ---
Source:
Server Name: WORK

Mar 18, 2010 at 9:47 AM
OK thx I'll have a look into this..
Mar 18, 2010 at 9:47 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Apr 2, 2010 at 8:02 PM

I'm getting this error on a new install, 2.0.7. Followed the install instructions on the download page. Added a few catagories with sub catagories. Then started adding products. Click the copy button, get the copy OK popup, then get sent to the Store Menu page with the error "Object reference not set to an instance of an object." If I reenter the backoffice the product is sucessfully copied and I can edit it. My store isn't live and I can give someone access if they want to see the problem.

Thanks.


AssemblyVersion: 04.09.05
PortalID: 11
PortalName: Jenkins Sails
UserID: 1
UserName: host
ActiveTabID: 465
ActiveTabName: Store Menu
RawURL: /StoreMenu/ctl/AdminProduct/mid/922?SkinSrc=%2fDesktopModules%2fNB_Store%2fSkins%2fStoreAdmin%2fNB_StoreAdmin
AbsoluteURL: /Default.aspx
AbsoluteURLReferrer: http://www.jenkinssails.com/StoreMenu/ctl/AdminProduct/mid/922?SkinSrc=%2fDesktopModules%2fNB_Store%2fSkins%2fStoreAdmin%2fNB_StoreAdmin
UserAgent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB6.4; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider
ExceptionGUID: cfed1753-ad46-42fb-8216-9b958dd7ba12
InnerException: Object reference not set to an instance of an object.
FileName:
FileLineNumber: 0
FileColumnNumber: 0
Method: NEvoWeb.Modules.NB_Store.ProductController.CopyModels
StackTrace:
Message: DotNetNuke.Services.Exceptions.PageLoadException: Object reference not set to an instance of an object. ---> System.NullReferenceException: Object reference not set to an instance of an object. at NEvoWeb.Modules.NB_Store.ProductController.CopyModels(Int32 ProductID, String Lang, Int32 NewProductID, LocaleCollection supportedLanguages) at NEvoWeb.Modules.NB_Store.ProductController.CopyProduct(Int32 ProductID) at NEvoWeb.Modules.NB_Store.AdminProductList.dgProducts_ItemCommand(Object source, DataGridCommandEventArgs e) at System.Web.UI.WebControls.DataGrid.OnItemCommand(DataGridCommandEventArgs e) at System.Web.UI.WebControls.DataGrid.OnBubbleEvent(Object source, EventArgs e) at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) at System.Web.UI.WebControls.DataGridItem.OnBubbleEvent(Object source, EventArgs e) at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) at System.Web.UI.WebControls.ImageButton.OnCommand(CommandEventArgs e) at System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) at System.Web.UI.WebControls.ImageButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) --- End of inner exception stack trace ---
Source:
Server Name: CELEBORN

Apr 3, 2010 at 8:36 AM

Hi,

I've got it!! the problem only exists when it's a new product and the model hasn;t had the weight saved to the shipping system.

I've put a fix in the v2.0.11 beta5 for this, you can download  it from the download page.

Thank you to both of you for reporting this.

Regards,

Dave.