Catalogue -> categories missing in back office, version 2.3.8 NBStore

Oct 31, 2013 at 10:19 PM
Extensions installed and used here and there:

DotNetNuke 7.0.6, iFinity URL Master 2.8.6, avt.Search 2.9.43, DNN Quick Form 1.0.1, SunBlog 6.1.0

Multi-lingual (2 languages)

Applied changes to ifinity url master to not rewrite skinsrc as URL parameter. Resulting URL in backoffice is:

Skinsrc is not being removed. Tested as normal user and host superuser. Only Dashboard and Reports button showing. No categories, no stock.

Tested on Chrome and IE 10. In Console in Chrome no errors.

When I manually change the URL to:

(so 'adminproducts' -> 'admincategories') I can edit the categories.

So it seems a UI bug, but not critical as long a you know the URL-s :-)

Any advice how to get categories and stock back in the screen?
Nov 1, 2013 at 5:01 PM

Are you running in a sub-portal? looks like it with the "store" in the url. If so, this is not supported by NB_Store. I suggest you run NB_Store in a normal portal environment with it's own url.

Nov 1, 2013 at 5:02 PM
by "sub-portal", I mean "child portal"
Nov 1, 2013 at 5:36 PM
As far as I understand DotNetNuke, we are not running child portals.

We have one portalid (1). However, the site has various site aliases (Site settings->Advanced on the site), such as:

These aliases are used to determine in which language the pages should be displayed (multi-language site).

This mapping is done using iFinity Master URL form Portal URLs.

If you like, I can provide a temporary root account/pwd. If that helps making NBStore better, please send me an email.
Nov 2, 2013 at 2:31 AM
The first thing I would do is turn off the url rewriter. If it then works, then that needs to be sorted out in the URL rewriter configuration.

If it doesn't work with the url rewriter disabled, then it sounds like a permissions issue, however the Host account shouldn't have that issue.

If it doesn't work with the url rewriter disabled, leave it disabled, click my name and send me a login, I'll have a quick look.
Nov 2, 2013 at 12:10 PM

Catalog page:

Directly below div with class: NBright_ui-tabs-ul there is:
<table class="NBright_ui-subtabs"><tbody><tr><td><a href=""><img src="/DesktopModules/NB_Store/img/tabmenu/ProductTab.png" alt="" border="0" align="absmiddle" title=""> Producten</a></td><td><a href=""><img src="/DesktopModules/NB_Store/img/tabmenu/CategoriesTab.png" alt="" border="0" align="absmiddle" title=""> Categorieën</a></td><td><a href=""><img src="/DesktopModules/NB_Store/img/tabmenu/StockTab.png" alt="" border="0" align="absmiddle" title=""> Koersdiagram</a></td></tr></tbody></table> After reactivating, the URL for the catalog page is:

Got it working again by replacing 'adminproduct' by 'AdminProduct'.
Nov 2, 2013 at 12:12 PM
Workaround using ifinity URL:
in Advanced settings I've added to forceLowerCaseRegex: (Store|store)/(Back|back)

This of course depends on your URL.
Marked as answer by monty24 on 11/2/2013 at 4:22 AM
Nov 2, 2013 at 12:21 PM
I have been looking around the source code, but I am unable to find the exact cause. For some reason, the subtabs defined in menu.xml are not included, whereas the tabs are. I think a structural change in the source code is needed, since more and more people are using lowercase only URL-s for better readability.