Image cannot upload

Jun 29, 2009 at 10:37 AM

Not sure if this is the right section to post. Can anyone point me why I'm getting this error during inser image to product. Existing and new products.

 

A critical error has occurred.
Violation of UNIQUE KEY constraint 'IX_FolderPermission'. Cannot insert duplicate key in object 'dbo.FolderPermission'. The statement has been terminated.

 

Thanks

Jun 29, 2009 at 11:22 AM

Hi,

It sounds like your DNN file system is not in-line with your actual file system, go into DNN filemager and re-sync folder and subfolder.

After that it should upload OK.

 

Jul 1, 2009 at 8:28 PM
Edited Jul 1, 2009 at 8:29 PM

I have encountered a couple of problems since I moved my local DNN4.9.2 site (with NB_Store) to a server.

First, I cleaned-up shop, and decided to start from scratch building my Shop online, so I used the HOST backoffice function to "Delete All Store Contents".

Now, when I add new products I get the following message, even tho the products get added, I then get the same message when I modify the products to add cost information:

A critical error has occurred.
Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

I also receive the same message that prevents me from associating images with the products.

I have checked permissions, and the VIEW is enabled under the DNN File Managment for ALL. I have re-synched the files of the folder & subfolder (productimage) - and I see all the product files in the proper folder.

Any ideas out there? I appreciate any help out there! Thanks.

Jul 2, 2009 at 8:01 AM

Hi dbs,

This sound like the server is running in "medium trust" mode.

What version of NB_Store are you running?

If it's less than 1.1.6 then there is a know issue, you'll have to upgrade to v1.1.6 where the medium trust issue has been fixed.

Regards,

Dave.

Jul 2, 2009 at 4:33 PM

Yes, I'm running NB_Store v1.1.05. Can you advise me on how to upgrade to v1.1.06? Does it require an uninstall and then complete new install? Thanks for your help.

Jul 2, 2009 at 4:42 PM

No, All you should do is just install the new v1.1.6 as a normal module. (I'd recommend making a backup of your database and installtion, if possible.)  Also be aware a bug was reported on overwriting the default templates (fixed in v1.1.7) so  if you've edited the default templates make sure you've got a backup. (use DNN export option to Export the BackOffice module)

Regards,

Dave.

Jul 3, 2009 at 3:32 AM

Thank you! I followed your directions and have eliminated all the errors at this time. I do, however, have one outstanding item regarding the product images. They are currently all on the server under the portal's productimages directory. I have been able to associate an image with a product provided that I upload it from my local (and I don't know where it goes on the server, as I haven't found it, yet). However, since all the product image files currently are already under the productimages directory, I don't want to have to re-upload each image, and I would prefer to associate the images from that directory to the products directly. When I edit a product, I only see the link to upload new image as opposed to linking to an existing image. Where would I make this association? Thanks for any help you can provide! THANKS!

Jul 3, 2009 at 7:58 AM

Yes, this is because the image path is different on your server to what it was on you local build.  Go into the BackOffice>Host tab and select store validation, it will automatically re-link the image paths to what they should be.

Regards,

Dave.