Can't get shipping to calculate

Sep 20, 2009 at 8:34 AM

Dave,

Whatever I do, I get a shipping cost of -1.

I'm now just trying to keep it simple to make it work.

Got one standard method.

In by weight, have 0.00 to 0.99 with 0 shipping cost (for downloadable stuff like AV software), and 1.00 to 100 cost of $15.

Nothing entered in any of the other tabs.

What have I done wrong?

John.

 

Coordinator
Sep 20, 2009 at 10:01 AM

Hi John,

A shipping cost of -1 is shown when NB_Store can't calculate a shipping cost (If you want a message appearing you'll have to set show shipping methods in the checkout module settings).  It sounds like you've not got any weight on your products or the combined weight of the cart is greater than 100.

I usually always make sure a shipping cost can be calculated every time. (The -1 means something isn't calcuating as expected)

To fix this you can

1 - add a default weight for the product "BackOffice>Shipping>By Product" or add a weight for each product.

2 - Change you range for $15 to 1 - 99999

also if you want to have no shipping you can set the "BackOffice>Shipping>Free Limt" to "0.00", be careful if you want to do this, because if "0.00" Free  Shipping limit means no shipping will be calcuated.  To remove it you must use the "Delete" button, the only difference you'll see is that the free limit amount will change from "0.00" (set to zero) to "0" (No free limit set, and the shipping will try to calcuatate).

The shipping can get complicated, but it should be working OK.

Regards.

Dave.

Sep 30, 2009 at 10:35 AM

Dave,

Getting there.

Got the shipping working for products we ship. Based on Price.

However, can't get downloadable products to work.

I have four shipping methods: download, metro, region1, region2

By weight for shpping method download I have 0 to 1 0 cost, 1.01 to 99.99 15.00

All other shipping methods have no entry in the by weight table.

By price: shipping method download has 0 to 9999.99 zero cost

all other methods have price breaks from 0 to 299.99, 300 to 2999.99 and 3000 to 9999.99. These all work.

By qty, By Country, By product no entries at all.

Free limit is 10,000

In the cart the three methos for metro, region1 and region 2 all display.

However the download method doesn't display.

What have I done wrong? I've tried various combinations and just can't get the no shipping for download to work.

John.

 

 

 

Coordinator
Sep 30, 2009 at 12:17 PM

Hi John,

Have you tried giving the downloadable products weight of 0.01.. this should then force them into the calcualtion and hence give you a download shipping method.

Regards,
Dave.

Sep 30, 2009 at 10:25 PM

Dave,

I managed to get the download to appear, but it doesn't work as it should.

It only appears if the by weight cost is greater than the by price cost.  If I set the by weight cost to zero, it doesn't appear. The best option I get if I set the by weight to $0.01, which looks pretty unprofessional.

I suspect it's a problem with the formula that doesn't like to the freight cost to come out at zero.

If I disable all the by price shipping options, and just do by weight, if it calculates to zero it doesn't like it and I get -1.

I think it must be an issue with the formula. I'm using v 1.02

What about being able to add an option to either the shipping method or to the by product (category) calculation that says this one has no freight.

That way you could have an option of customer pickkup that is zero freight, or you could have it by product or category that the product doesn't incur freight. For products/categories you could put this option in the catalog section. Then in the freight calc have a simple test that says "if product.freefeightflag = true then freight = 0"

In reality we often sell computers with antivirus, or firewalls with subcription options. You normally wouldn't want these to be included in freight calcs.

I also have another suggestion, but I'll start a new discussion for that.

John.

 

Coordinator
Oct 1, 2009 at 5:09 AM

Hi John.

I've had another problem reported on Product weights, so I'll look into this at the same time and see if I can get a solution for you.

Regards,

Dave.

 

Coordinator
Oct 1, 2009 at 5:33 AM

Hi John.

Just an update I've been doing some testing on the shipping problem and I think your issue is linked, hopfully we will have a solution by the end of the week.

Regards,

Dave.

 

Nov 17, 2009 at 3:21 AM

Dave,

Any news on this.

Seems that if the shipping calcuates to zero, you get an error.

 

JJ

 

Coordinator
Nov 17, 2009 at 7:14 AM

Hi JJ,

I think this has been resolved in the lasest beta. v2.0.4 beta11.

I not heared anybody else having issues, what exactly is your error message?

Regards,

Dave.