module export/import missing

Sep 21, 2009 at 12:10 PM
Edited Sep 21, 2009 at 12:21 PM

i can't copy productlist modules to another export/ import funtions are missing from menu.
Checkout this and inform

Another interesting point. When you have more than 1 productlist on the same page.
copying product content to another and using second module settings (same as first one use) productlist are not looking the same as first one.
settings have been changed some way or another.
I hope module export/import menu functions helps in this problematic situation.
Expecting fixed until 1.1.2 will be lanuched.
Never been before these functions have been lost somewhere.

Regards,

Markku

By the way when will discount options be launched. deadline?

Coordinator
Sep 21, 2009 at 1:08 PM

Hi Marku,

On the Import and Export, they should definatly be there. (Just checked my test account and eveything is OK)  Sometimes this is a problem with DNN not picking up the methods by reflection and hence no import/export menu.  To fix this go into Host>Modules select the productlist module and check that in "Controller Class:" the Nevoweb BasePortController is specified.  Then simply update, this should make the module update it's definition in the DB and hopfully you'll get the import/export options.

If not it may be a problem during installation.  In which case re-installing should solve the problem.

The first time the productlist module loads it takes the default settings, this could explain the issue when copying productlist modules, but after you've setting it up it should kept what you've done.

Hopefully looking at getting a beta for the discounts out by the end of the week...In alpha test now.

Regards,

Dave


 

Sep 21, 2009 at 2:13 PM
Edited Sep 21, 2009 at 3:42 PM


Now updating after installation module setting helped,

This was the first time this problem occurs in DNN 5.1.2 version used.

Here is after installation business ckass settings. NEvoWeb.Modules.NB_Store.ProductListController,NEvoweb.DNN.Modules.NB_Store
So baseportController does not be installed. i tried onece again
Below is probably one reason to this

in baseportcontroller:   DotNetNuke.Entities.Portals.PortalSettings.GetModuleSettings(ModuleID) is obsolete (Deprecated DNN 5.0 or later).

Should be:  DotNetNuke.Entities.Portals.PortalSettings.ModuleController.ModuleSettings(ModuleId)  using DNN 5.1.2

That could be the reason.

Second one: resolved (template table settings to be changed) helped!

Last one: i appreciate that.
Any Comments

Regards,

Markku