error upload images

Oct 15, 2009 at 12:43 PM

Hello, when I upload an image, the system to create a record in table ProductImage with this record

ImagePath: c:\DotNetNuke\portals\7\productimages\6_0fdc6.jpg

ImageURL:/DotNetNuke/portals/7/productimages/6_0fdc6.jpg

two fields by separate are correct, but the system detects as an
errors I read in the help document
"...This will check to see if the imagepath in the NB_Store_ProductImage table matches the Server Root MapPath + imageURL.  If it does not and the FIX error has been checked, the imagepath is updated with the Server Root MapPath + imageURL path, if this file doesn't exist the productimage record is removed from the database..."

but not be such as changing the parameters to make this work.
Thank you

Coordinator
Oct 15, 2009 at 1:34 PM

Hi Alfonso,

I'm not sure what your telling me?

Are you saying that when you run store validation this image comes up as an error, even though it's correct?

or

Are you saying the store validation doesn;t fix the problem?

or

Are you saying the image doesn't display on the product list and details?

Regards,

Dave.

Oct 15, 2009 at 1:43 PM

You must apologise because my English isn't  very well

When I think a product and I add an image with the backoffice is when the record,  before I talk about has been created, but by clicking the checking store it  indicates that there is an error and if I check Fix, then clear the record, but  Imagepath  and UrlPath like well.

Coordinator
Oct 15, 2009 at 1:51 PM

I think I understand!.

Firstly have you made sure that the image actually exists in the "productimages" directory after upload?

Second, What version of NB_Store are you using?

What version of DNN are you using?

 

 

Oct 15, 2009 at 1:59 PM

yes the file exist and the web page displays it if  I don't Fix the error but  anything you need to do in the BackOffice, this closes
and asking for the login.

Im use Nb_store 1.1.7 but first it provides with version 1.2.1 with the same results so i think that version have a bug

im downgrade to it

And Dnn version is DNN (c.e) 5.1.4

and Sql is server 2005 developer edition

Run in Win 2003

Coordinator
Oct 15, 2009 at 2:49 PM

I've never had a problem with this, but I'm running DNN4.  I've also not heared of a problem in DNN5.  However I'll doing some tests against DNN5 and get back to you on this.

Did you say that your being logged off for no reason?

Regards,

Dave.

Oct 15, 2009 at 2:55 PM

yes, directily send to login page, and when i log in again resume to the last state

Coordinator
Oct 15, 2009 at 2:57 PM

Does it do the same if your logged in as host??

 

Oct 15, 2009 at 3:11 PM

ok, when i logged in as Host don't  logout to me.

Coordinator
Oct 15, 2009 at 3:31 PM

I think this may be an issue with your DNN installation.  I've had a simular issue before and trace the problem to DNN trying to get security based on tabid, I've fixed the tabid issue by using a workaround in NB_Store, but it appears there is also somethingelse.  I never found the time to trace the exact problem in DNN, but creating a new installation of DNN solved our problem.

I know it's a pain, but if you try creating a new installation of DNN you may find the problem is fixed.

Regards,

Dave.

 

Oct 15, 2009 at 4:22 PM

The installation is very recent, recently I had to start from scratch by giving me an error an update of the dnn,

I also have other portals with a complex structure on the server.
Start from scratch would be a disaster.

Now I  create a user as host to create Products and then what I will be a .net program to migrate from my server ERP articles to SQL Server, 

Once everything parameterized and translated into Spanish don't have to enter the backoffice.
If you find any possible solution or test done I would be very grateful I indicate to make it

Coordinator
Oct 15, 2009 at 4:31 PM

OK, I'm running test for beta8 now, I'll let you know if I find anything to help

Coordinator
Oct 16, 2009 at 9:43 AM

Hi Alfonso,

I've just uploaded v1.2.2 to codeplex, this has a fix to the get model SQL, I've not been able to recreate the problem with users being logged off yet, but I think you should try this new release and see if it solve any of your problems.

Please let me know how it goes,

Regards,

Dave.

 

Oct 16, 2009 at 10:52 AM

Yesterday I upgrade to 1.2.1

now i upgrade to 1.2.2 and when i Enter in backoffice page it say

Upgrade of Settings Failed. ManagerMenuDefault.xml version 01.02.01 mismatch with NB_Store version 01.02.02

and it work like others versions and I see in product manament in image control that not appears the icon with image (show a cross) unless enter as host .

 

Coordinator
Oct 16, 2009 at 11:04 AM

OK,

The version message is because I've forgot to update the version in a control file, and has no effect...thankyou for pointing it out, I'll fix that.

The fact the host user can see everything, seems to indicate a permissions problem, check in DNN filemanager to make sure the permissions on the "productimage" and "productdoc" directories has read write access for eveyone.

 

Coordinator
Oct 16, 2009 at 11:07 AM

I've updated codeplex with the correct control file version, download and install NB_Store again and the "failed version" message should disappear.

Oct 16, 2009 at 11:26 AM

I change manually the xlm file

I have checked the rights groups by sql and in the web and all are allowed.

If you want to check my system I can publish portal and give you an account as a host

Coordinator
Oct 16, 2009 at 1:43 PM

hi Alfonso,

Ideally if you can zip your DNN installation and DB and send it to me I'll be able to have a look whats happening.

Contact me through codeplex and I'll give you a link where you can upload the zipped files.

Dave.

 

Oct 16, 2009 at 4:24 PM

I have make any changes in dnn instalation and reconfigure it to remove the virtual directory and it look well but have the same problem with images products only that now don't  say any error only dont show in other users and exit to login page

in few moments send a zip a replica of my dnn

Oct 16, 2009 at 4:54 PM

at what email  i can sent this files?

Coordinator
Oct 16, 2009 at 5:05 PM
Edited Oct 16, 2009 at 5:06 PM

Click on my contact name "leedavi" and send a message to me then I'll be able to email you a link where you can upload the zip files.

Coordinator
Oct 18, 2009 at 9:10 PM

Hi Alfonso,

The good news is I think your DNN Installation is OK, I can't see any problems.

The bad news (for you) is that I could not see any problems with the NB_Store module either!!!

I restored your Installation on my PC running windows XP, IIS5 and SQL Server 2008.

I went to the BackOffcie>Admin and did the store validation, this fixed the images and they now appear on the Product list and product details pages.

This makes me think the DNN and NB_Store are OK in your installation and the problem may be with the hosting setup.

What Server setup do you have?  and are you running medium trust?

Regards,

Dave.

Oct 19, 2009 at 9:30 AM

Its Installed under Win 2003 and Sql2005 Devedition in DNN (ce edition)

and confure with module DNN_ActiveDirectoryAuthentication and access allow anonimus conection

But i Dont Know what you want sau whit  "and are you running medium trust"

 

Coordinator
Oct 19, 2009 at 7:58 PM

You configuration is much the same as my office test server, so I'm unsure why your having issues.

"Medium Trust" means your running iis with a level of security for users that doesn't allow certain file/disk operations, NB_Store does run in medium trust, but is not fully tested in medium trust.  If you've setup your hosting yourself and used normal defaults you shouldn't be runnig medium trust.

I really can't think of an obvious reason why your DNN Installation and NB_Store works OK on my PC, but doesn;t seem to work on your configuration!

Is there any other information you can give that my help to find out what's happening?

Regards,

Dave.

 

 

Oct 20, 2009 at 5:55 PM

I Analyze the web.config searching the level of trust that i use and i think mi problem is that in other portal i use Active directory validation and this change the trust lines,

lines 105, 114 and 135 like can see you see.

Coordinator
Oct 24, 2009 at 4:59 PM

Hi Alfonso,

I'll try and find the time to have a look into this and see if I can understand what's happening.

Regards,

Dave.