Product options not appearing

Jan 19, 2010 at 9:37 PM

when i'm adding ontions to the product like colour memory or stuff of that kind it would show up anywhere on the product's deltail page or check out

what can i do to solve this??

Coordinator
Jan 19, 2010 at 11:42 PM

Hi there,

Each model or option has to have the relevant tokens present in the product list and details templates. The default templates don't contain all possible tokens, nor do they support more than one of each. If that is in fact the problem here, then what you need to do is create templates that have sufficient model and option tokens for your purposes.

Find the list of tokens in the documentation.html inside the module zip. You'll see notes on how to add more than one of each token by inserting a number inside the brackets after the token name [token1], [token2] etc. In my case I've made default templates allowing for 3 models, 3 options, 3 documents and so on. That's plenty.

Let us know if that resolves it.

Rob

Jan 20, 2010 at 3:44 AM
Edited Jan 20, 2010 at 10:18 PM
this is what i mean
when i create a new product and i want to add options:
Coordinator
Jan 20, 2010 at 4:07 AM

I'm afraid I don't quite follow. Codeplex probably messed up what you were pasting in.

Can you send a link, or if you want to post a screenshot, use a free image hosting service like http://www.thumbsnap.com/

Regards,
Rob

Jan 20, 2010 at 7:26 PM

when i type in option: 
 http://www.pucho.ca/options.png

They come out like this:
http://www.pucho.ca/option2.png

other them this small problem i have been very happy with the NB Store especially the shipping rates by country!

 

Coordinator
Jan 20, 2010 at 9:15 PM

Ok, I see what you mean.

The first place we need to look is in the details template.

Can you check which details template is specified in the product list module settings and then copy and paste that template in here. Use the HTML button on the toolbar of the forum editor when pasting.

Perhaps also edit the post above with all the code in it, so that it doesn't stretch this page so wide.

Rob

Jan 20, 2010 at 10:23 PM
Edited Jan 20, 2010 at 10:24 PM

ok i looked in productdetail.template and i got

 

Return
[TAG:IMAGELIGHTBOX]
[TAG:GALLERY2]
[TAG:GALLERY3]
[TAG:GALLERY4]
[TAG:GALLERY5]

[TAG:PRODUCTNAME]

[TAG:DESCRIPTION] Price:$ [TAG:FROMPRICE] [TAG:EDITLINK]
[TAG:OPTIONNAME1][TAG:MODELS] Quantity : [TAG:QTY][TAG:ADDTOBASKET]

but i also found productdetail2.template

 

[TAG:IMAGE] [TAG:SUMMARY]
[TAG:DESCRIPTION]
 
[TAG:MODELS] Qty :[TAG:QTY]
[TAG:OPTIONNAME1] [TAG:OPTION1]
[TAG:OPTIONNAME2] [TAG:OPTION2]
[TAG:OPTIONNAME3] [TAG:OPTION3]
[TAG:ADDTOBASKET] Return[TAG:EDITLINK]
 I use productdetail.template so i would like to fix that one if is possilbe
Coordinator
Jan 20, 2010 at 11:26 PM

Hi, thanks for editing the post above.

ok, I can see from the tags that your website probably has "productdetail.template" applied.

  • See where the productdetail.template says: "[TAG:OPTIONNAME1][TAG:MODELS] Quantity : [TAG:QTY][TAG:ADDTOBASKET]"
    That is what you are seeing on your details page.
     
  • See how the productdetail2.template says: "[TAG:OPTIONNAME1] [TAG:OPTION1]"
    That is what you need to have in your template so that the options display.

The solution is:

  1. Change the "Details Template" in your "NB_Store_ProductList" module to "productdetail2.template".
    This will look different, but it will demonstrate the product options for you.
     
  2. Go back to my first reply in this discussion thread. It has the information you needed to know, and it will lead you towards modifying the existing template or creating a new one.

Note: In future the store will have a default template available that contains a complete selection of tokens. That's on my to-do list.

Regards,
Rob

Jan 21, 2010 at 12:06 AM

thanks for all the help i managed to modify the original  productdetail.template so now it works to my advantage

i put in the options:
http://www.pucho.ca/optionfix.png

it worked:
http://www.pucho.ca/optionfix2.png

and this is the code i used to fix the problem
http://www.pucho.ca/codeiused.png

 i made it a list because of the amount of options I need to offer

thanks again for the help!

Miguel

Coordinator
Jan 21, 2010 at 12:20 AM

Excellent, great to hear it's now working :D

Here's a related tip for when one has lots of options that are the same across different products:

  • Create a blank product and give it all the default options you need. Then use the "Copy Product" button in the back Office each time a new product is added. One could have several of these blank products ready for different purposes.

Rob

Feb 16, 2010 at 8:29 PM

Hi,

My store has a huge list of products and each have a lot of the same options. I tried using the "Copy Product " button but I'm getting the error saying  "A critical error has occurred, Object reference not set to an instance of an object." I would really appreciate it if this could be fixed so I may work faster creating my store.

Thanks.

Joe

Coordinator
Feb 16, 2010 at 8:48 PM

Hi Joe,

(Please start a new thread with new questions.)

Can you let us know which version of the cart you have installed on which version of DNN... also go to the Admin, Event Log and see if you can find the full error message. Paste it in here and let's see what it says.

Regards,
Rob