Buy button works in edit mode but not in view mode

Mar 19, 2010 at 3:28 PM
Edited Mar 19, 2010 at 4:45 PM

Hi I have created a little shop for our whisky community. Now I have come to a problem which I can not solve at the moment. In the store module I use productdetail2.template. Now when I click on the buy link in edit mode, the product is added to my cart and I am redirected to my cart. However, when I want to do the same in view mode, the shop template seems to refresh but nothing happens, that means, nothing is added to the cart. Can it have something to do with the category menu? In edit mode, the categories on the shop module change when I click on the Categories Links, but in view mode this does not happen.

Can anbody help me with this problem? Many thanks in advance.

René Blanc

Coordinator
Mar 21, 2010 at 5:57 AM

Hi Rene.

Somethings not right here!!...When you say View Mode, is this the DNN view mode, but you are still connected as host?....The first thing to try would be to see what happens when you completly logged out...Also owhich browser are you using?

From the sound of the problem , it could be a js clash?....have you got any js errors appearing on the page?

Like on the other thread that reported something simular, have you tried removing and putting the module back on?

I've never had any problems with the add button, but now your the second person to mention this, so there could be some kind of combination of things happening to cause this situation.  Have you got a version of the website I could look at to see if I can find any issue?

Regards,

Dave.

 

Mar 21, 2010 at 6:01 PM

Hi Dave,

When I say View Mode, i mean the DNN view mode. I tried to log out and log in again. I also logged in as a registered member without having edit mode permission. Also as a normal registered user I could not add any products to my cart. Logging in again as superuser, going into edit mode, I could add products the normal way, going into view mode it dit not work. I am not a js specialist, I remember that on the lefthand bottom of my page but outside the module (I think) there was a js sentence. Unfortunately I cannot access my server at the moment to see whether that sentence is still there. But I do not think that this was an error message, at least it had no error mention.

The problem is, that I can not say, when the problem first appeared. I did some changes on some of the templates but nothing serious and I always worked in edit mode where everything worked well. Only when I finally wanted to test some permission options between different user roles I noticed the problem.

However, as I have seen that another person had the same problem, I did the same as the other person suggested, I deleted the productlist module from the page and added it again, and everything works fine now. And I think that that Js sentence on the lefthand bottom is still there.