01.01.05 LocalHost Upgrade

Mar 20, 2009 at 7:11 AM
I upgraded my LocalHost test installation from 01.01.01 to 01.01.05 followed the instructions regarding NB_Store Menu and Back Office. When I try to enter the Back Office I receive the following error:

A critical error has occurred.
The virtual path '/DesktopModules/NB_Store/Skins/StoreAdmim/NB_StoreAdmin' maps to another application, which is not allowed.

Any Ideas?

Cheers
Dennis
Mar 20, 2009 at 8:12 AM
Hi Dennis,

I think this may be due to you running DNN in a Virtual Directory, I'll have to do some tests to prove this, but one thing you could try is to edit the "/Desktopmodules/NB_Store/xml/MainMenu.xml" file and change the Skin path attribute to reflect your full path. (i.e. put on the virtual directory at the front of the path)

I'll have a look at get back to you later today.

Thanks for the feedback.

Regards,
Dave.
Mar 20, 2009 at 8:20 AM
One thing to note!  NB_Store caches the MainMenu.xml when it first opens it, so if you make changes to the MainMenu.xml you'll have to restart the application, from "Host>Configuration" - "Restart Application" button, in order for the changes to be picked up.
Mar 20, 2009 at 5:58 PM
Hi,

I've just uploaded version 01.01.05 beta1a,  I think this should solve your problem,  please let me know?

Regards,
Dave.
Apr 1, 2009 at 2:10 PM
Edited Apr 1, 2009 at 2:39 PM
Dave, I'm running into the same issue "The virtual path '/DesktopModules/NB_Store/Skins/StoreAdmim/NB_StoreAdmin' maps to another application, which is not allowed."  I have downloaded and installed what appears to be version "01.01.05 beta1a" but the zip I download is named "... beta1" and the version that shows on the DNN Module Definistions screen is 01.01.05.  How do I know if what I have is actually beta1a and not beta1.

I tried restarting the application from the Host Settings page and even tried "iisreset" but I still get the error.

Thanks,
Chuck


P.S. this was a fresh install on my local machine.  It is also running under a localhost virtual directory.
Apr 1, 2009 at 2:43 PM
Dave,  FYI...

I just installed the module on a "real" web server (no virtual directories involved) and the error does not occur.  I'm still not sure of the version (beta1 or beta1a).  I do need to be able to install and run on my local development machine in order to confirm functionality so if you could rectify the issue it would be of great help.

Thanks and I really like the "Dashboard".  It's a big improvement!

Regards,
Chuck
Apr 2, 2009 at 4:59 AM
Hi Chuck,

I've got a project I need to finish off today, but as soon as that's out of the way I'll look at the NB_Store issue and get back to you.  Also you don't have to run your DNN from a virtual directory on localhost (Although the virtual directory issue does needs resolving!!), have a look at this link...

http://www.developerfusion.com/code/4645/multiple-iis-virtual-servers-on-xp-pro/

Also I've just searched for the link and found http://www.codeplex.com/iisadmin,  I'm going to look at this also when I get chance!!

Regards,
Dave.



Apr 2, 2009 at 7:55 AM
Hi Chuck,

I've just got into work, so I've picked up the beta1a version and uploaded it to codeplex again, it looks like I might have uploaded the wrong version last time.  Give it a try and let me knnow if it works OK.

Regards,
Dave.
Apr 2, 2009 at 5:19 PM
Thanks Dave!  I'll try downloading the new version and let you know how it goes.

Alos, thanks for the iisadmin link.  Sounds like this could be the answer to a number of issues related to virtual directories. I'll look at that too.
Apr 2, 2009 at 5:36 PM
Dave, I just installed the "real" beta1a and the error did not occur!!!  Looks like your fix worked.

Thanks again.