Cannot change lightbox template

Jul 16, 2009 at 2:13 PM

Hello!

Can you help me with the following issue: When I'm trying to change the lightbox.template (for example to remove border and so on), it changing perfectly in fck editor, then I save it, but in productdetail.tempate it shows me the old one, with old formatting.

Thank you in advance!

Alex

Jul 16, 2009 at 2:25 PM

HI,

What version of NB_Store are you using?

v1.1.7 Beta has had the addition of caching on the templates, this could be causing the issue.  Try restarting the DNN application to clear the cache, also make sure your browser cache is clear.

Regards,

Dave.

Jul 16, 2009 at 2:40 PM

Dave,

I'm using the 01.01.06 version of NB_Store. I cleared all caches - on DNN and in the browser, cleared PageBlaster cache - no results. If I change productlist.template I see the results immediately, in lightbox.template and lightboxgallery.template the changes do not work.

Best regards,

Alex

Jul 16, 2009 at 3:05 PM

OK, I think I might know what's wrong.  In v1.1.6 I changed the lightbox to be a jQuery one called nyromodel to be the default lightbox, using a default template of "nyromodal.template".  Also there is a option to specify your own lightbox template by using the "lightboxtemplate.name", check if this exists, if it doesn't then there is a good chance that your using the "nyromodal.template".

Just to make things a bit more confusing, we found an  issue with the nyromodel running in standard compliance mode in IE8, so in version 1.1.7 we changed it again to another jQuery lightbox!!...Sorry!

Have a look at the documentation.html included in the v1.1.6 installation and it'll expalin a bit more.

Regards,

Dave.

Jul 16, 2009 at 3:13 PM

Dave,

I have upgraded up to 1.1.7 beta, changed the jquery and now all is working! Thanks a lot!

Best regards,

Alex

Aug 28, 2009 at 6:07 AM

Thanks for this information! I am about to get my client's site online, and they were unhappy with the borders, so I had tried a number of methods, then scanned the discussion forum, and alas, the solution was here! Because I'm so close to the launch date, I didn't upgrade to the beta version, but I did just remove the borders from the Nyro templates (standard and gallery), and that did the trick.

Thanks for providing this very useful forum and a wonderful product!

Sep 4, 2009 at 3:17 PM
leedavi wrote:

...
Also there is a option to specify your own lightbox template by using the "lightboxtemplate.name", check if this exists, if it doesn't then there is a good chance that your using the "nyromodal.template".
...

Can you tell me where this options would be, if it exists?  I would like to create a different gallery template without destroying the built in ones.  Using v01.01.06 as well.

Thanks!