02.00.04 Back Office Message

Nov 17, 2009 at 4:45 AM
Edited Nov 17, 2009 at 4:46 AM

Just installed this module and get the following message on the back-office module.  Any ideas.  I am a noob, so go easy!

Upgrade of Settings Failed. ManagerMenuDefault.xml version 02.00.03 mismatch with NB_Store version 02.00.04

Thanks!


Nov 17, 2009 at 6:58 AM

Hi!

U should use Nb_Store ver 02.02.02, the newest version, i am using it, very ok. Good luck

Coordinator
Nov 17, 2009 at 8:00 AM

Hi Jimjust,

The message is just a warning that the settings version is lower than the current version.....A problem where I've forgotten to update the version number in the settings import file (I'm a noob). 

Check if you've got settings in the store BackOffice>Utilites>Settings.   If you have then the message should not effect anything.  However In order to solve the problem I've upload Beta11a to codeplex, download this and install.  It should fix the problem with the message.

Thanks for pointing this out.

Regards,

Dave.

 

Nov 18, 2009 at 2:01 AM
Edited Nov 18, 2009 at 2:38 AM

INstalled Beta11a and problem solved!  Thank you!

Coordinator
Nov 21, 2009 at 11:59 AM

Hi Dave,

I've just had the same error after going from NB_Store_02.00.04_Install_Beta11a to NB_Store_02.00.05_Install_Beta12

"Upgrade of Settings Failed. ManagerMenuDefault.xml version 02.00.03 mismatch with NB_Store version 02.00.05"

Rob

Coordinator
Nov 21, 2009 at 12:04 PM

Though oddly, only one portal reports the issue... the others aren't saying anything.

 

Coordinator
Nov 21, 2009 at 7:16 PM

Hi Rob,

I think this must be a cache issue, I've checked the version in the source and they look OK, The message itself is just a warning and doesn;t have an effect on the operation (Unless you need something in the new templates..not in this case). I would just wait for your server cache to clear and see then..or if you really want to just restart DNN app.

Regards,

Dave.

Coordinator
Nov 21, 2009 at 11:28 PM

Hi Dave, this is weird. I've restarted and the message remains, just in the one portal still. Is there a particular token I should be checking for? I've already replaced OrderUser:Email with Order:Email in the portals that have anonymous purchasing.

I'll examine the templates in this portal more closely in a moment and see if I can find anything missing.

Rob

Coordinator
Nov 22, 2009 at 4:45 AM

Hi Rob,

Strange...I'll have a look at the code and see if I can find any issue with the version message in a multiple portal situation.

However what you can do is update the "version" setting to match the current release number, change the setting from "02.00.03" to "02.00.05".  This should stop the message.

Regards,

Dave.

Coordinator
Nov 22, 2009 at 5:20 AM

ahh good stuff, that solves it nicely :D