Upgrade of Settings failed. 02.00.07 mismatch with 2.00.06

Dec 9, 2009 at 10:47 PM

I just upgraded from 1.02 to the latest 2.0.7, but the Module Definitions page shows '2.0.6' for all the NB_Store modules.

Also, I get the following error when I go to the Backoffice page:

Upgrade of Settings Failed. ManagerMenuDefault.xml version 02.00.07 mismatch with NB_Store version 02.00.06.

Dec 10, 2009 at 5:36 PM

Have same error on localhost.

Dec 11, 2009 at 2:19 AM

Same issue here

Coordinator
Dec 11, 2009 at 5:37 AM

It's likely just not packaged quite right, so until Dave can look at it, you can probably stop the message appearing by checking for a setting in back office, utilities, settings, called "version" and put 02.00.07 in it.

Rob

Dec 11, 2009 at 9:49 AM

Hi tried the above but didnt work...

 

However this did:

 

Modify the install zip as follows:

 

Extract the 2 files NB_Store.dnn and 02.00.06.SqlDataProvider

 

Open the first file in notepad, replace all occurencies of 02.00.06 with 02.00.07

Save the file.

 

Next rename the 02.00.06.SqlDataProvider file to 02.00.07.SqlDataProvider

 

Now drag these files back into the zip file.

 

Install as usual, worked fine for me :)

 

You shouldn't have any knock on effects for this when upgrading to 02.00.08 when its released but don't hold me responsible

Coordinator
Dec 14, 2009 at 2:42 PM

Hi Guy's

Sorry I forgot to update the version in the manifesto file.   I've done this not and uploaded the package on codplex.

Thanks for pointing it out.

This is just a version control issue and should not effect anything else, because there was no DB SQL updates from 2.0.6 to 2.0.7, it was just a change to add the cookie option to the checkout for security in multi user PC situation.

Regards,

Dave