nb_store and google chrome

Dec 23, 2009 at 11:15 AM

Hi,

I tested nb-store with google chrome.
The only (little) error I noticed, is with the cattegory tree view menu.
The little + sign to expand/collapse a category are not vissible.
Is there a solution for this?

Regards, Ton Hermes

Dec 23, 2009 at 10:52 PM

hmm yes, the same happens in Opera as well. I'll make this a work item and look into it.

Regards,
Rob

Dec 23, 2009 at 10:53 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jan 5, 2010 at 7:53 AM

Ton, can you check your site again and see if this is still happening?

I've returned after the Xmas break and am no longer seeing a problem here in either Chrome, Safari or Opera- although I'm sure I did see it at the time.

Drop me a link in if possible.

Rob

Jan 5, 2010 at 8:17 AM

@Rob,

I've just had a look and the problem still seems to be there  for me??....now it's also there in FF, whcih was working before?

I'll email you the link I have.

Jan 5, 2010 at 11:52 AM
Edited Jan 5, 2010 at 11:54 AM

Hi,

The problems is in IE8 also.
Only in compatible view the + sign is visable

With regards, Ton Hermes

Jan 5, 2010 at 12:08 PM

ok, can you replace the contents of your jquery.treeview.css with the following and confirm that it works:

.treeview,.treeview ul,.treeview li{list-style:none;}
.treeview,.treeview ul {padding:0;margin:0;}
.treeview ul{margin-top:4px;}
.treeview .hitarea{background:url(/DesktopModules/NB_Store/img/treeview-default.gif) -64px -25px no-repeat;height:16px;width:16px;margin-left:-16px;float:left;cursor:pointer;}
/* fix for IE6 */
* html .hitarea{display:inline;float:none;}
.treeview li{margin:0;padding:3px 0pt 3px 16px;}
.treeview a.selected{}
#treecontrol{margin:1em 0;display:none;}
.treeview .hover{cursor:pointer;text-decoration:none}
.treeview li{background:url(/DesktopModules/NB_Store/img/treeview-default-line.gif) 0 0 no-repeat;}
.treeview li.collapsable, .treeview li.expandable{background-position:0 -176px;}
.treeview .expandable-hitarea{background-position:-80px -3px;}
.treeview li.last{background-position:0 -1766px;}
.treeview li.lastCollapsable, .treeview li.lastExpandable{background-image:url(/DesktopModules/NB_Store/img/treeview-default.gif);}
.treeview li.lastCollapsable{background-position:0 -111px;}
.treeview li.lastExpandable{background-position:-32px -67px;}
.treeview div.lastCollapsable-hitarea, .treeview div.lastExpandable-hitarea{background-position:0;}
.treeview-red li{background-image:url(/DesktopModules/NB_Store/img/treeview-red-line.gif);}
.treeview-red .hitarea, .treeview-red li.lastCollapsable, .treeview-red li.lastExpandable{background-image:url(/DesktopModules/NB_Store/img/treeview-red.gif);}
.treeview-black li{background-image:url(/DesktopModules/NB_Store/img/treeview-black-line.gif);}
.treeview-black .hitarea, .treeview-black li.lastCollapsable, .treeview-black li.lastExpandable{background-image:url(/DesktopModules/NB_Store/img/treeview-black.gif);}
.treeview-gray li{background-image:url(/DesktopModules/NB_Store/img/treeview-gray-line.gif);}
.treeview-gray .hitarea, .treeview-gray li.lastCollapsable, .treeview-gray li.lastExpandable{background-image:url(/DesktopModules/NB_Store/img/treeview-gray.gif);}
.treeview-famfamfam li{background-image:url(/DesktopModules/NB_Store/img/treeview-famfamfam-line.gif);}
.treeview-famfamfam .hitarea, .treeview-famfamfam li.lastCollapsable, .treeview-famfamfam li.lastExpandable{background-image:url(/DesktopModules/NB_Store/img/treeview-famfamfam.gif);}
.filetree li{padding:3px 0 2px 16px;}
.filetree span.folder, .filetree span.file{padding:1px 0 1px 16px;display:block;}
.filetree span.folder{background:url(/DesktopModules/NB_Store/img/folder.gif) 0 0 no-repeat;}
.filetree li.expandable span.folder{background:url(/DesktopModules/NB_Store/img/folder-closed.gif) 0 0 no-repeat;}
.filetree span.file{background:url(/DesktopModules/NB_Store/img/file.gif) 0 0 no-repeat;}
/* Tweaks */
.treeview a{position:relative;top:-2px;left:2px}
Jan 5, 2010 at 1:38 PM

Hi Rob,

Works in Firefox, IE8 and Google chrome

With regards, Ton

Jan 5, 2010 at 9:50 PM

Good stuff :D

Dave, let's go with that. The only non-standard tweak in my css above is the line at the end which aligns the menu items with the icons a little better - you can remove that if you prefer.

Regards,
Rob

Jan 6, 2010 at 7:22 AM

Hi

Just a little question left about this.
I like to give the links another color.
So I changed the following.

.treeview a.selected
{
color: #003366;
}

However, this only affect the selected link.
What syntax I have to use to get all the links an other color?

Regards, Ton

Jan 6, 2010 at 8:14 AM

Hi Ton,

These will get you going:

.treeview a{}
.treeview a:hover{}
.treeview a.selected{}

Rob
Jan 6, 2010 at 4:21 PM

Hi Rob,

It works perfect.
Thanks.

Regards, Ton

Mar 20, 2010 at 9:47 PM

I found a problem. When adding links to photos, you can't save them. The box just sits there until you cancel it. I'm doing this in the category message. Not sure if it's the same elsewhere.

 

JJ

Mar 21, 2010 at 6:49 AM

Hi JJ,

Not sure if you've put this on the right thread?, but the image link in the categoriesis a file upload.  Are you selecting your image and then clicking the "Add" button?

Regards,

Dave

Mar 21, 2010 at 6:59 AM

Dave,

Problem is with Google Chrome. It works in Firefox. When you edit an image and try and add a link (doesn't matter whether it's to a page or a url, you can't save the changes. Only way is to use Firefox.

Even if you are adding an image, once you add a link to the image you can't save the changes. Give it a go.

JJ

Mar 22, 2010 at 8:55 AM

Hi JJ,

I must be missing something, I'm not sure what you mean by link???..

But when I Add an image to either a category or products everything seem to work OK in Chrome?.... I have v4.1.249.1036 of Chrome.   Is this what you mean by link, "Uploading an image" or do you mean somethign else?

 

Regards,

Dave.

Mar 22, 2010 at 12:24 PM

Dave,

I can add the image ok. But if you go to the link tab, and add a link, then you can't save it. Or if you already have an image and select image properties, and go to the link tab, you can't save the changes. I've got the same build as you. Running on Windows 7 Ultimate.

JJ.

Mar 22, 2010 at 2:01 PM
Hi JJ, Sorry, but your going to have to talk me through this one slowly!!.. Link tab?.....what link tab? I don;t quite understand what your trying to do.....can you explain from the begining. Are you talking about the FCK Editor? Thanks, Dave.
Mar 22, 2010 at 9:59 PM

In the editor, right click on any image, and then select image properties.

You get a pop up that has three tabs: image info, link and advanced.

However, even though I haven't done anything different it's now working.....

If you clicked on the link tab and add a link, then you couldn't close the popup using OK. You could only cancel it, and the changes weren't saved.

It was when editing the message in the category. I'm now suspecting that there must be some other condition that triggers this issue. If I discover something I'll let you know.

 

 

Mar 23, 2010 at 7:44 AM
Hi JJ, This looks like some issue with FCKEditor and Chrome. NB_Store just uses the DNN editor, so we have no control over the editor option working or not! But I did try what you suggested in Chrome and it work OK for me? Regards, Dave