Copy Product option not working?

Jan 8, 2010 at 4:42 AM

Hi guys, anyone try to copy a product from the admin panel?  I have a product that i try to copy, I get the pop-up alert asking if I'm sure, I click yes, but nothing happens.  Any Ideas?

Jan 8, 2010 at 5:37 AM


Strange, I use this function all the time, and I've not heared anyone else complain about it.

It should create another product identical, but with the word "[copy]" after the product name.   If your not getting this then have a look at the dnn log to see if your getting any errors.



Jan 8, 2010 at 6:11 AM
Edited Jan 8, 2010 at 6:15 AM

Hi Dave, Nope no errors recorded in the Event Log.  I tried it using both IE8 and Chrome just to be sure. I also checked the SQL table to be sure.  The progress bar does appear, like it's processing something, but when it finishes, there's no copy generated.

Jan 8, 2010 at 8:48 AM


What version of NB_Store and DNN are you using?


Jan 8, 2010 at 8:55 AM

I'm using DNN Version 05.02.01 using SQL 2008 and IIS6, and NB_Store version 2.0.7   Is there a stored procedure responsible for this?  

Jan 8, 2010 at 9:10 AM

I've just tried it on my DNN5 test account and the page doesn;t refresh like it does in DNN4, however when I clicked the product list again the [copy] product was there.  Is this what is happening?  or do you not get the [copy] at all?

(The copy function is done via code in the dll, not by a store procedure.)

Jan 8, 2010 at 9:17 AM

Nope, I tried that too, still no new [copy].  Are there some fields that are required that might stop the process.  I'm not receiving any error messages at all either.

Jan 8, 2010 at 9:34 AM

No, I can;t think of fiedl that would cause this, but maybe the many languages do you have on your site and what are they?


Jan 8, 2010 at 9:35 AM

I only have the en-US language pack installed.

Jan 8, 2010 at 9:43 AM

Can you export you products and email them to me, so I can test them on my system.


Jan 8, 2010 at 6:13 PM

Dave, I've tried using the export button from the admin panel, but when I open the xml file it's empty, no products are listed.  If you send me your email address, I will set up an admin account for you to login and see for yourself if you'd like.


Jan 8, 2010 at 8:54 PM

OK, Rick.  There is something strange going on here.   I'll send you an email you can reply to.

I'll not be in the office until Monday, but will have a look then.




Jan 10, 2010 at 10:12 PM

Hi Dave, just an FYI that I resolved the issue.  After hours of digging on the internet, it turns out that my DNN install was missing the default "GlobalResources.resx" file in the App_GlobalResources directory off the DNN root folder.  I tried just copying the missing file and then restarting the application, but still got the same error.  It wasn't until I re-copied all the files from the DNN upgrade package that it resolved itself.  

Another side effect of not having this file in place was that I was unable to upload any modules using the install wizard.

Suffice to say, the "copy" product option now works as intended.  Dave, is there any way to sort the product list differently?  Now that I have several items I have to scroll tot he page to find the product I want to copy, and then when i do make the copy, I have to scroll again to find the newly made copy before I can edit it.  Time consuming yes, but I'm still grateful the copy option works now!

Note to everyone, if you try this option make sure to make a full back up copy of your DNN install AND your SQL database first.  Trust me, not a mistake I'll make again anytime soon :)


Jan 10, 2010 at 10:47 PM

That's great to hear it's sorted out Rick.

About the other issue - Rest assured that's already on the list of enhancements to be discussed for the roadmap shortly. It's a real usability problem that.